Repository navigation
Conversation
Live Debugger Runtime BenchmarkSDK-loaded dormant-probe runtime overhead, measured against an uninstrumented bundle in the same browser session.
What do the Tiny and Hot workloads represent? Browser Debugger SDK: Full diagnosticsRaw samples are in the |
|
@codex review |
Codex Review SummaryThis comment shows the latest Codex review activity on this pull request.
ℹ️ About Codex in GitHubYour team has set up Codex to review pull requests in this repo. Reviews are triggered when you
Codex reacts with 👀 while any review is running, comments if it has suggestions, and reacts with 👍 once all reviews finish with no findings. |
There was a problem hiding this comment.
💡 Codex Review
Here are some automated review suggestions for this pull request.
Reviewed commit: 249346b996
ℹ️ About Codex in GitHub
Your team has set up Codex to review pull requests in this repo. Reviews are triggered when you
- Open a pull request for review
- Mark a draft as ready
- Comment "@codex review".
If Codex has suggestions, it will comment; otherwise it will react with 👍.
Codex can also answer questions or update the PR. Try commenting "@codex address that feedback".
There was a problem hiding this comment.
🔵 Needs a closer look
The shared Node runtime upgrade still needs confirmation from cross-bundler CI and end-to-end checks beyond the reported unit-suite results.
No open issues 🎉
What changed in this PR
This PR raises the Datadog Vite plugin’s minimum supported version to 6.4 and moves the repository’s shared Node runtime pin to Node 24.
Changes:
- Narrows the Vite peer range to
>=6.4.0 <9and documents the major-version migration. - Adds an advisory startup warning for older Vite versions, with tests for version detection and logging behavior.
- Updates the Volta Node pin from
20.19.4to24.14.1.
| File | Description |
|---|---|
yarn.lock |
Synchronizes the Vite peer range. |
packages/published/vite-plugin/package.json |
Declares the new Vite support range. |
packages/factory/src/index.ts |
Logs the unsupported-Vite warning during initialization. |
packages/factory/src/index.test.ts |
Tests warning behavior and disabled logging. |
packages/factory/src/helpers/vite-version.ts |
Defines the minimum version, check, and warning message. |
packages/factory/src/helpers/vite-version.test.ts |
Tests version boundaries and unreadable inputs. |
package.json |
Pins the repository runtime to Node 24.14.1. |
MIGRATIONS.md |
Documents the Vite requirement for v4. |
Review effort: Balanced
6d0d8b6 to
85dc584
Compare
The peer range becomes `>=6.4.0 <9`, and the startup warning names that range for a Vite outside it, asking for Vite 6.4 or later below it, since Yarn and pnpm only warn about a peer range and npm's check can be skipped. A test ties the check's bounds to the peer range in package.json. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
85dc584 to
b079239
Compare
Motivation
@datadog/vite-pluginstill declaresvite >= 5.x <= 8.x.vite >=6.4.0 <9and warns at startup outside it. Yarn and pnpm only warn about a peer range, and npm's refusal can be skipped with--legacy-peer-deps, so the startup warning is what reaches every user.semverparsing and the Node 24 pin.Changes
3 changes across vite-version.ts, vite-version.test.ts and vite-plugin/package.json
vite-version.tsvite-version.test.tsvite >=6.4.0 <9.vite-plugin/package.jsonQA Instructions
b079239f. Setup: build-plugins: Testing and QA Guide.npm installon Vite 5.4.21ERESOLVE: npm refuses the narrowed peer range--legacy-peer-deps, thenvite buildon Vite 5.4.21 and 6.3.5Datadog's Vite plugin supports Vite 6.4.0 to 8.x (found 5.4.21): please upgrade to Vite 6.4 or later.vite buildon Vite 6.4.5 and 8.3.4✓ built in 30msand22msTMPDIR=/private/tmp yarn test:unitbelowrun.shand its outputBlast Radius
ERESOLVEon a fresh install or update that picks up this version,~ranges included, until they upgrade Vite or pass--legacy-peer-deps.Out of Scope / Follow-ups
3 items deferred
Documentation
🤖 Generated with Claude Code