Repository navigation
fix(security): sharp 0.35.5 in root package-lock.json (GHSA-wq5f-xc86-pv6w, alert #55) - #35
Open
benfrank241 wants to merge 1 commit into
Open
benfrank241 wants to merge 1 commit into
benfrank241 wants to merge 1 commit into
Conversation
…-pv6w) Raise the existing sharp override ^0.35.0 -> ^0.35.5 (next 15.5.28 already requests ^0.34.3 || ^0.35.5). Relocked with npm install --package-lock-only; libc markers on @next/swc-linux-* restored after the macOS relock. Closes Dependabot alert #55. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Security bundle: npm, root
package-lock.jsonCloses Dependabot alert #55:
sharpGHSA-wq5f-xc86-pv6w (high), vulnerable< 0.35.5, fixed in 0.35.5.Change
package.jsonoverrides:"sharp": "^0.35.0"->"sharp": "^0.35.5". This is a patch bump in the same minor.next@15.5.28already requestssharp ^0.34.3 || ^0.35.5, so the override now agrees with the parent.package-lock.json: regenerated withnpm install --package-lock-only --ignore-scripts. sharp 0.35.4 -> 0.35.5, plus the matching@img/sharp-*0.35.5 and@img/sharp-libvips-*1.3.4 binaries. Nothing else changed: the diff is 119+/119-, all version, resolved and integrity lines.libc: ["glibc"]/["musl"]markers on the four@next/swc-linux-*entries. I restored them verbatim frommainso Linux installs still pick the right binary.Verification (local, node 22.22.3 / npm 10.9.8)
npm ci: oknpm run build(tsup, CJS/ESM/DTS): oktestandlintscripts: not defined in this packagerequire('sharp')reports sharp 0.35.5 / vips 8.18.7 and renders a 2x2 PNG.Supersedes the sharp part of the earlier sweep backlog note on #30. Opened by the daily security sweep. Do not merge without review.
🤖 Generated with Claude Code