Repository navigation
fix(deps): bump filelock to 4.2.4, test group on Python 3.11+ - #58
Merged
Merged
Conversation
Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_01QUnP8iomGUAisq7SWJwEkA
Codex Review SummaryThis comment shows the latest Codex review activity on this pull request.
ℹ️ About Codex in GitHubYour team has set up Codex to review pull requests in this repo. Reviews are triggered when you
Codex reacts with 👀 while any review is running, comments if it has suggestions, and reacts with 👍 once all reviews finish with no findings. |
☂️ Code Coverage
Overall Coverage
New FilesNo new covered files... Modified FilesNo covered modified files...
|
🖌 Pre-commit success 🏆DetailsExit code: 0 Author ✍️@brtkwr |
Puvendhan
approved these changes
Oct 28, 2026
Puvendhan
left a comment
There was a problem hiding this comment.
LGTM. filelock 4.2.4 in the test group, which now needs 3.11. The hooks still support 3.10.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Context
Three open Dependabot alerts on
filelockinuv.lock(1 high, 2 low), all fixed in filelock 4.2.1, which requires Python 3.11 or newer. filelock is dev tooling only here (pulled in by pre-commit/virtualenv in thetestdependency group).Changes
[tool.uv.dependency-groups]entry:test = { requires-python = ">=3.11" }, so uv resolves that group for 3.11+ only and the lock holds a single filelock 4.2.4requires-python = ">=3.10": these hooks are installed by pre-commit in consumer repos, and about 15 of them run pre-commit on Python 3.10 (airflow-integration and two-logger pinpython3.10as the default language version), so a 3.11 floor would break hook installation thereuv sync --all-groupsnow needs 3.11. No release needed, consumers pin tagsScope / Non-goals
uv sync(with thetestgroup) now needs Python 3.11+; CI no longer exercises 3.10 itselfValidation
uv lock --upgrade-package "filelock>=4.2.1": lock now holds a single filelock 4.2.4 entry, the only other changes are 3.10-only entries dropping out (backports, and older duplicate versions that existed just for the 3.10 fork)Ticket
🤖 Generated with Claude Code
https://claude.ai/code/session_01QUnP8iomGUAisq7SWJwEkA