Repository navigation
chore: update Node to 26 LTS and override vulnerable glob - #143
Merged
Merged
Conversation
Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com>
jhnns
added a commit
to peerigon/template-public-package
that referenced
this pull request
Nov 1, 2026
Pulls in the latest changes from `peerigon/template` (peerigon#143). Updates Node to 26.13.0 in `devEngines`, adds an override forcing `glob@^13.0.6` for `ts-lsp-mcp` to avoid a vulnerable version, and regenerates `package-lock.json`. No other files changed. 🤖 Generated with [Claude Code](https://claude.com/claude-code) Co-authored-by: Claude Sonnet 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Bumps
devEngines.runtimefrom Node 24.18.0 to 26.13.0, the latest LTS (CI picks it up vianode-version-file). Adds an override forcingts-lsp-mcpto useglob@^13.0.6instead of the deprecated, vulnerableglob@10.5.0. The lockfile is updated accordingly.glob@14.0.3would also fix a newer advisory but is blocked by the 7-daymin-release-ageuntil about 2026-11-03.🤖 Generated with Claude Code