Repository navigation
fix(deps): upgrade vulnerable dependencies - #11
Open
reformedot wants to merge 2 commits into
Open
reformedot wants to merge 2 commits into
reformedot wants to merge 2 commits into
Conversation
next 16.3.3 is affected by GHSA-2464-fhr4-w9xw, GHSA-673q-mjm6-r5xr and GHSA-vcvr-r3jv-pc5j (critical); 16.4.1 is the lowest patched release. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
reformedot
force-pushed
the
security/dependency-upgrades-2026-10
branch
from
October 23, 2026 01:38
98b8c35 to
5f70f00
Compare
Updates every critical/high alert in the lockfiles this PR touches that a patch or minor bump fixes (lowest fixed versions; blocked ones are listed in the PR body). Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Purpose
This PR closes Dependabot security alerts for SOC 2 compliance.
It upgrades
nextto the lowest patched version in the same major version.The diff changes only the version spec and the lockfile.
Changes
nextpackage.json,package-lock.jsonPatch and minor updates in rounds 3 to 5
These updates stay inside the existing version ranges and use the lowest fixed version per installed major line, unless a section below says otherwise. Changes in
package.jsonare marked.package-lock.json: dompurify 3.4.14 -> 3.4.17; source-map-js 1.2.1 -> 1.2.2Alert status
Computed on 2026-10-23 about 06:29 UTC. Closed counts: open Dependabot alerts (including
package.json/pyproject.tomlalerts whose lockfile is in this PR) that the branch no longer matches. An alert counts as closed only when no installed version in its manifest stays in the vulnerable range. Remaining alerts: every lockfile that this PR changes, plus anybun.lock/bun.lockbin the same folders, checked with OSV and GitHub severities; advisories published after 04:10 UTC are not included. The Advisories column counts critical and high advisories per installed version. Dependabot can show fewer alerts, because it has one alert per package and manifest, and some advisories have no Dependabot alert.Open Dependabot alerts that this branch closes: 0 critical, 1 high, 0 medium, 0 low.
No critical or high alert remains in these lockfiles.
Local verification
typescript7.0.2 as a devDependency.next buildadds it by itself whentypescriptis missing. This PR no longer has that change:package.jsonchanges onlynext. So the CIbuildjob fails with "It looks like you're trying to use TypeScript but do not have the required package(s) installed". Themainbranch fails CI with the same error since 2026-08-27: the first failing run is https://github.com/browser-use/browser-agent-template/actions/runs/33027124296 (d217cef), and the run on the currentmainhead aae9334 is https://github.com/browser-use/browser-agent-template/actions/runs/33280503230. Addingtypescriptas a devDependency fixes the build, in this PR or in a separate one.npm ci && npm run build: pass.npm run typecheck: pass.next16.4.1 requiressharp^0.35.5, so the lockfile also updatessharp0.35.4 -> 0.35.5.osv-scannershows that all listed advisories are closed forpackage-lock.json.🤖 Generated with Claude Code