Skip to content

fix(deps): resolve dependabot security alerts - #13

Merged
JairajJangle merged 3 commits into
mainfrom
fix/dependabot-security-2026-08
Aug 18, 2026
Merged

JairajJangle merged 3 commits into
mainfrom
fix/dependabot-security-2026-08

Conversation

@JairajJangle

Copy link
Copy Markdown
Owner

Resolves all fixable open Dependabot alerts by bumping vulnerable transitive dependencies. Dev tooling only — no runtime dependency or source change. Lockfile regenerated from a clean resolve; tests, typecheck, lint, and build all pass.

Resolves 79 of 83 open Dependabot alerts (73 npm + 6 Ruby).

Recursive transitive upgrades (yarn up -R), no manifest changes:
fast-uri 3.1.0 -> 3.1.5, js-yaml 3.14.2/4.1.1 -> 3.15.1/4.3.1,
undici 7.21.0 -> 7.29.0, ip-address 10.1.0 -> 10.5.0,
brace-expansion 1.1.12/5.0.5 -> 1.1.18/5.0.9, tar 7.5.7 -> 7.5.22,
shell-quote 1.8.3 -> 1.10.0, sigstore 4.1.0 -> 4.1.1,
@sigstore/verify 3.1.0 -> 3.1.1, @sigstore/core 3.1.0 -> 3.2.1,
@babel/core 7.29.0 -> 7.29.7,
@babel/plugin-transform-modules-systemjs 7.29.0 -> 7.29.8,
launch-editor 2.12.0 -> 2.14.1, tmp 0.2.5 -> 0.2.7,
basic-ftp 5.2.0 -> 5.3.1, defu 6.1.4 -> 6.1.7,
lodash/lodash-es 4.17.23 -> 4.18.1, node-forge 1.3.3 -> 1.4.0,
flatted 3.3.3 -> 3.4.4, picomatch 2.3.1/4.0.3 -> 2.3.2/4.0.5,
minimatch 3.1.2/9.0.5/10.1.2 -> 3.1.5/9.0.9/10.2.6.

Narrow resolutions where a dependent pinned a vulnerable range:
- undici@6.23.0 -> ^6.28.0 (release-it pins 6.23.0 exactly)
- qs@~6.14.0 -> ^6.15.2 (body-parser pins ~6.14.0)
- fast-xml-parser@^4.4.1 -> ^5.7.0 (@react-native-community/cli-*;
  4.x has no patch for GHSA-gh4j-gqv2-49f6)

example/Gemfile: activesupport floor >= 7.2.3.1, concurrent-ruby
>= 1.3.7, < 1.4 (lifts the stale < 1.3.4 pin).

turbo remains on 1.13.4: the patched 2.9.14 requires a major bump of
a direct devDependency plus a turbo.json pipeline -> tasks migration.
…bumps

Descriptor-keyed `resolutions` entries only apply while some dependent
declares exactly the matching range. Where the patched transitive can
come from the dependency graph naturally, prefer that over an override.

Bumped (in-major, within the existing declared range):
- @react-native-community/cli 20.1.1 -> 20.2.0 (declared as ">=18.0.1";
  package.json range unchanged, lockfile refreshed)
  - cli-config-android / cli-platform-apple now require
    fast-xml-parser ^5.3.6, so 5.11.0 is picked naturally
  - cli-server-api now requires body-parser ^2.2.2 (2.3.0), which
    requires qs ^6.14.1, so 6.15.3 is picked naturally

Dropped overrides (now redundant):
- "qs@~6.14.0": "^6.15.2"          -> qs still resolves to 6.15.3
- "fast-xml-parser@^4.4.1": "^5.7.0" -> still resolves to 5.11.0

Kept override:
- "undici@6.23.0": "^6.28.0" - release-it 19.2.4 is the newest 19.x and
  pins `undici` to exactly 6.23.0; no in-major bump can replace this,
  and removing it would reintroduce the vulnerable undici.

Also corrects example/Gemfile ruby floor to ">= 3.1.0" to match the
activesupport 7.2.x line already required there.

No security regression: every package patched by c87ce8a resolves at or
above its patched version (verified by lockfile diff).
@JairajJangle
JairajJangle merged commit c6ed2de into main Aug 18, 2026
7 checks passed
@github-actions

Copy link
Copy Markdown

🎉 This PR is included in version 1.1.7 🎉

The release is available on:

Your semantic-release bot 📦🚀

@JairajJangle
JairajJangle deleted the fix/dependabot-security-2026-08 branch August 18, 2026 12:24
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant